Nvidia Brightness

Plasma 4 Extensions

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
7 .5
Description:

Small plasmoid for controlling brightness of LCD in laptops with smartdimmer tool installed - I guess it exists only on laptops with Nvidia graphic cards.

Install: plasmapkg -i nvidia-brightness.zip
Use +/- plasmoid buttons or mouse wheel while over the plasmoid to change brightness.

Tested on Sony Vaio AW31, with smartdimmer version: NVClock SmartDimmer adjustment tool version 0.8b4
Last changelog:

10 years ago

1.0 - first version. And propably the last for a long time...

d4v1dv00

10 years ago

neither the button or mouse wheel works on this widget under KDE 4.4.1

i am using nVidia GeForce 8600GT

Report

C

matemaciek

10 years ago

- Did it work on your comp on earlier KDEs?

- I've just installed KDE 4.4.1 on my laptop, I'll check this evening if it works on it, if not I'll try to post new version.

Report

d4v1dv00

10 years ago

never tried it as I just discover this applet.

thanks.

Report

C

matemaciek

10 years ago

Is smartdimmer working on your comp? Try:
smartdimmer -g
from command line, it should return current brightness.
smartdimmer -s val
should set brightness to val.

Report

d4v1dv00

10 years ago

smartdimmer does not work with my Dell laptop, here is the message:

Error!
Smartdimmer is only supported on certain (HP/SamsungSony/Zepto) laptops using a Geforce 6200/7x00Go/8x00Go. If you want support on your laptop contact the author.

any chances your current/future version can work?

Report

C

matemaciek

10 years ago

I'm affraid no )-: My widget uses smartdimmer, so as long as there is no working smartdimmer for your laptop, my plasmoid won't work.

If you have some programming/Linux skills, you can try to change plasmoid source to control brightness in your PC - you have to find the right command for your laptop, maybe something like echo brightnessVal >/some/brightness/file.

Or maybe as the error is saying, contact the autor of smartdimmer (-:

Report

10 years ago

1.0 - first version. And propably the last for a long time...

12345678910
7
product-maker akinms Nov 02 2011 9 excellent
product-maker tcat Aug 30 2011 9 excellent
product-maker tomasz-dziekan Aug 27 2011 9 excellent
product-maker czarny777 May 19 2011 9 excellent
product-maker jorizma Apr 08 2011 9 excellent
product-maker Ilu Jan 28 2011 9 excellent
product-maker alltiptop Jan 15 2011 9 excellent
product-maker Base: 4 x 5.0 Ratings
Be the first to comment
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
1.0
updated Oct 31 2009
added Oct 31 2009
downloads 24h
0
mediaviews 24h 0
pageviews 24h 2