TextShadowEdit

Various KDE 1.-4. Improvements

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

0
5.0
Description:

This is a simple Control Center module one can use to change the look of the shadows under the desktop icons.

Many people complained about ugly default shadows, but there was no easy way (say a GUI) to change this.

You can use this little tool to change this.

Have fun!

Please let me know if it was useful for you.
Last changelog:

16 years ago

05/01/03 - V0.1.1
- Decay-Combo now enables the Apply-Button.
- No debug-messages anymore
- Fixed the build-system
- Removed dummy-docs -> results in smaller source-package
- Removed some unneeded files from the package

05/01/01 - V0.1 initial release

jaugen

16 years ago

I receive this error message:

Making all in po
make[2]: Entering directory `/mnt/hda6/Applications/KDE/textshadowedit-0.1/po'
make[2]: *** No rule to make target `de.po', needed by `de.gmo'. Stop.
make[2]: Leaving directory `/mnt/hda6/Applications/KDE/textshadowedit-0.1/po'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/mnt/hda6/Applications/KDE/textshadowedit-0.1'
make: *** [all] Error 2

This would be a great module to have. Any suggestions?

Report

C

SegFault

16 years ago

Try it with
make -f Makefile.cvs
./configure
make
make install

Tell me, if you had success with this.

Report

shadowrm

16 years ago

i also got the same error and when i tried make -f Makefile.cvs ( which i've done before successfully on other apps ) i received:

*********
This Makefile is only for the CVS repository
This will be deleted before making the distribution

*** YOU'RE USING automake (GNU automake) 1.9.3.
*** KDE requires automake 1.6
make[1]: *** [cvs] Error 1
make: *** [all] Error 2
*********

i have no idea why that happened lol :D thanks for any feedback!

Report

C

SegFault

16 years ago

Hmm...
Then make a copy of po/textshadowedit.pot to po/de.po
This should do the trick ;-)

Report

shadowrm

16 years ago

heres what i did:

*****
cd po/
cp kcmtextshadowedit.pot de.po
*****

now when i did make -f Makefile.cvs it failed... intresting, but who cares - so i ran ./configure --prefix=/opt/kde3 and make and volia! its good! ( at first i forgot to add the --prefix and nearly posted when i was like, oh wait, thats right -- i'm retarded :D ) thanks for the excellent work! and your prompt response! i posted this instead of 'thanks' just incase someone else hits this problem too ;-) again, thanks for the work!

Report

IceSheep

16 years ago

Thanks a lot! I had the same problem and this thread has helped! :-)

Maybe it's a problem with a certain distribution. May I ask which one do you use? I've got a SUSE 9.2.

Report

shadowrm

16 years ago

yup, i've got SuSE 9.2 as well, fully updated using YOU. i thought it might be a problem with the distro because it looked like no one else was having the exact same problem with the weird de.po file. glad it helped you! ( thank SegFault too, he kicks a** at solving these types of problems! ) :D

Report

smileaf

16 years ago

I was thinking about attempting to do this when I saw the docs on icon shadowing.
only mine would have been a patch to kdebase. perhaps in the icons or something.. I don't know where does this fit?
perhaps this could be added in the head?

Report

C

SegFault

16 years ago

Yes, it would belong to kdebase.
I did this as a seperate module because there won't be that many people who are willing to patch and recompile their kdebase.
I wouldn't.
For developers it should be easy to integrate this in the "normal" codebase.

Report

yf12s

16 years ago

Well, for those of you who get configure errors about the files being from the future, you may want to run a make -f Makefile.cvs before running configure. That seemed to fix it.

Report

C

SegFault

16 years ago

Well...
Most certainly you live in a different timezone than me :-)
Just wait a few hours and this "bug" should go away :-)

Report

16 years ago

05/01/03 - V0.1.1
- Decay-Combo now enables the Apply-Button.
- No debug-messages anymore
- Fixed the build-system
- Removed dummy-docs -> results in smaller source-package
- Removed some unneeded files from the package

05/01/01 - V0.1 initial release

12345678910
Be the first to comment
File (click to download) Version Description PackagetypeArchitecture Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.1.1
updated Jan 03 2005
added Jan 01 2005
downloads 24h
0
mediaviews 24h 0
pageviews 24h 0