Metal4kde

KDE 3.5 Themes

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

3
5.0
Description:

just another metalic look for kde,
based on phase liquid and baghira.

i would be most thankfull for distro's rpm.

special 10x goes to timur from UsefulArts team for his GREAT support, for thomas the creator of baghira for him being kind enough to answer my emails, and for spasemunkie for contributing the progress-bar pixmaps (see - http://kde-look.org/content/show.php?content=20303)

proud sponsor UsefulArts.org


ScreenShots - a lot of pepole were asking so here it is:

OS - my beloved Gentoo :-)
docker - kxdocker
icons - SNOWE
karamba - cynapses
wallpaper - by varius artists including timur, all wallpapers can be found on this site
style - Metal4kde
winDeco - Metal4kde
Last changelog:

16 years ago

0.2 : add a matching winDeco

for full changeLog see Metal4kde homepage or ChangeLog file in the package.

carney1979

16 years ago

...and now suddenly it works on more apps such as Konqueror.

Strange, but welcome!

David

Report

C

motyR

16 years ago

have u installed the theme to your new kde 3.4 dir, or at list expend your $PATH to include both kde 3.3 and 3.4 dirs

Report

tomchilton

16 years ago

hey ive installed the style and applied it but its not been applied to the title bars and close/maximise buttons etc...any clues?
cheers

Report

C

motyR

16 years ago

hi tomchilton,

look at the screenshots section of my post.

Report

tomchilton

16 years ago

i see...duh
thankyou!

Report

hosti

16 years ago

I've got it. Great theme. Is it possible to send me / post the green color theme . (it's not included here)
tkx;

Report

hosti

16 years ago

i've installed everything without a problem on my suse (9.2), but i can't find this theme in my control center. Anyone know what's wrong ? Tkx in advance.

Report

skaterpunk0187

16 years ago

i'v done everything i have read to install this theme. i'v done then ./configure, make, make install. i canlt seem to apply the theme to kde

Report

C

motyR

16 years ago

hi,

on which distro? and what configure string r u using?

Report

skaterpunk0187

16 years ago

i'm running Gentoo and i used the ./configure --prefix=`kde-config --prefix`

Report

C

motyR

16 years ago

hi,
try to run some app with this style like
"konqueror --style Metal4kde" to see if he knows about the style, beside that i've built a gentoo ebuild u can use it instead http://kde-look.org/content/show.php?content=20260
jusr put it in the right place of your PORTDIR_OVERLAY and emerge it.

if u manage to install and run gentoo i'm preaty sure u'll be runing it with no time ;-)

Report

timur

16 years ago

A new beta release is available at http://www.onexige.com/metal

Report

timur

16 years ago

By the way... here's the URL of the bug reporting system, a useful way to improve metal4kde and help its development:

http://www.onexige.com/metal/bugfix.html

Report

Technaton

16 years ago

I'm using your theme for some weeks now, it's lovely :-)
But here are some suggestions for your next updates:
1. My tooltips are entirely black-in-black. I dont need them most of the time, but it looks ugly ;-)
2. I think the buttons' borders are too think. E.g., when using your theme with any IRC-Client (which displays open channels, queries, ... as buttons), it doesnt look too nice. Perhaps make them flatter, just try it.

Thanks alot for the great work! :-)

Report

C

motyR

16 years ago

hey Technaton,

first of all thanks for your comment,
about tool tips i'll chack it though on my machine i dont see tham as black, now about the buttons border could u please send me a screenshot of it to moty@onexige.com so i can see it.

BTW i kepp working on new features and polishing the old one and soon i'll realease a new update.

10x alot Technaton

Report

neonmagic

16 years ago

Hiya,

Successfully installed your theme (it looks very good!), but menus aren't themed. What am I missing? i've been thru the KDE control panel and can't seem to find any option to force the menus to use your theme.

Also - what icons are you using?

Dave

Report

neonmagic

16 years ago

OK, fixed menu as well, simple enough fix, although i'm not sure why it did what it did. Deselected both baghira and metal and re-enabled baghira first (kmenu was fine), then re-enabled metal and it remembered it correctly. Odd.

Also - bug when setting style back to default, and then trying to re-enable metal. kcontrol crashes, similar to the bug above. Fix? Re-enable baghira as the style first, then re-enable metal. Worked for me.

Dave

Report

neonmagic

16 years ago

Fixed it. Had menu transparency enabled, and that was overriding your theme. Turned it off and it worked a charm!

Now to see if that fixes the start menu as well ;-)

Dave

Report

timur

16 years ago

Post the bugs in the bug reporting system, this will make their fixing faster.

Report

jinksys

16 years ago

When I select this style in my kcontrol, it crashes kcontrol :(


Suse9.2
DUMP:
Using host libthread_db library "/lib/tls/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 1095666176 (LWP 16699)]
[KCrash handler]
#7 0x40b4c820 in QPainter::drawTiledPixmap ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#8 0x41b6e6eb in metalStyle::drawComplexControl ()
from /opt/kde3/lib/kde3/plugins/styles/metal.so
#9 0x40d1331d in QSlider::paintEvent () from /usr/lib/qt3/lib/libqt-mt.so.3
#10 0x40c27352 in QWidget::event () from /usr/lib/qt3/lib/libqt-mt.so.3
#11 0x40b8e85f in QApplication::internalNotify ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#12 0x40b90423 in QApplication::notify () from /usr/lib/qt3/lib/libqt-mt.so.3
#13 0x40820a91 in KApplication::notify () from /opt/kde3/lib/libkdecore.so.4
#14 0x40b5aa96 in QWidget::repaint () from /usr/lib/qt3/lib/libqt-mt.so.3
#15 0x40c2b421 in QWidget::repaint () from /usr/lib/qt3/lib/libqt-mt.so.3
#16 0x40b1d322 in QETWidget::translateConfigEvent ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#17 0x40b2aa22 in QApplication::x11ProcessEvent ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#18 0x40b3b908 in QEventLoop::processEvents ()
from /usr/lib/qt3/lib/libqt-mt.so.3
#19 0x40ba67b1 in QEventLoop::enterLoop () from /usr/lib/qt3/lib/libqt-mt.so.3
#20 0x40ba65f6 in QEventLoop::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#21 0x40b902ef in QApplication::exec () from /usr/lib/qt3/lib/libqt-mt.so.3
#22 0x416f1abd in kdemain () from /opt/kde3/lib/libkdeinit_kcontrol.so
#23 0x0804e7a6 in launch ()
#24 0x0804eebc in handle_launcher_request ()
#25 0x0804f479 in handle_requests ()
#26 0x0804fc5a in main ()

Report

ficken

16 years ago

Hello "motyR"

your theme looks very interesting!!!
I downloaded the sources and the rpm's.

When giving
"./configure --prefix=`kde-config--prefix`"

my bash complains with kde-config no prefix can be found...
nevertheless the installion runs!
after that i give make and make install

so the sources are installed correctly (i hope)

But now i click on the suse rpm's, yast is initialized and in the window the message "missing" is displayed.
I click on install package with yast and something happens (i hear it on the harddisk) but then, when searching the package in the software bundle, the metal theme is found, but there still stands "missing" and not more.

Do you have an idea what i've done wrong?

Report

C

motyR

16 years ago

hello ficken,

first of all i didnt get from your comment which suse r u runing, but the rpm is for suse 9.2

beside that for suse users u should install to /opt/kde3 so do as fallow:

./configure --prefix=/opt/kde3
make
su -c make install

hope it helps.

Report

ficken

16 years ago

Hello MotyR

great!!! It works. Yes i use the suse 9.2 distribution.
The problem was the prefix!
I forget to set it to /opt/kde3
thanks a lot to you....

now i really have a great looking destop environment.
The only thing i would like to know.....how did you set the colors of the baghira so that they look like the colors of your metal theme ? I cannot find the right option!

But thanks a lot! I'm really happy now :o)

Report

C

motyR

16 years ago

the color of the brushed metal r controled through baghira style config dialog, and u'll also add to chack the option "fallow style" in the baghira windeco config dialog.

Report

Lucas

16 years ago

hi,

i've managed to get it to install and i can select metal under the style option in kcontrol, but i still get nothing in the theme manager. activating the style gives me most of the look, but i'm missing the window decs that aren't available under window decs or theme manager.

if anyone could point out where the theme is located in the filesystem, i may be able to add it that way...

Thanks guys

Report

16 years ago

0.2 : add a matching winDeco

for full changeLog see Metal4kde homepage or ChangeLog file in the package.

12345678910
Be the first to comment
jennifergsmedley
Mar 13 2020
deprecat
Aug 05 2009
alecs1
Feb 15 2009
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.2
updated Mar 30 2005
added Oct 31 2004
downloads 24h
0
mediaviews 24h 0
pageviews 24h 5