syncekonnector

Groupware

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

1
Score 50.0%
Description:

This is a konnector-plugin for SynCE-KDE, which provides the functionality to synchronize Contacts, Appointments, and Todos between a Windows-CE device and a KDE-equipped desktop/laptop.
This konnector is based on the kitchensync framework.
Last changelog:

14 years ago

Initial version.

cloakable

12 years ago

I'm using Debian Etch, and have gotten Raki and syncekonnector to work on my Contacts, Tasks, and Appointments. However, I see quite a few other options in there (like bookmarks and files) that don't work - no synchroniser found. I fixed the same problem with the three working ones by installing ksync, but what do I do to get those working?

Report

crlshn

13 years ago

I had a trouble

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!

Report

Superstoned

13 years ago

here a raki crash too.

Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1477814592 (LWP 21049)]
(no debugging symbols found)
#6 0x08077223 in Rra::getTypes ()
#7 0x0806f0e8 in PDA::getSynchronizationTypes ()
#8 0x0806f517 in PDA::synchronizationTasks ()
#9 0x0807c313 in ThreadEventObject::customEvent ()
#10 0x4948e6f7 in QObject::event () from /usr/lib/libqt-mt.so.3
#11 0x494273f6 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#12 0x494275f2 in QApplication::notify () from /usr/lib/libqt-mt.so.3
#13 0x49b33f11 in KApplication::notify () from /usr/lib/libkdecore.so.4
#14 0x493b86f7 in QApplication::sendEvent () from /usr/lib/libqt-mt.so.3
#15 0x49428a47 in QApplication::sendPostedEvents ()
from /usr/lib/libqt-mt.so.3
#16 0x49428b4e in QApplication::sendPostedEvents ()
from /usr/lib/libqt-mt.so.3
#17 0x493cb9cb in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#18 0x4943fee7 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#19 0x4943fe0a in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#20 0x49425f05 in QApplication::exec () from /usr/lib/libqt-mt.so.3
#21 0x08067045 in main ()

it doesn't even start with a connected HP ipaq :(

Report

gentry76

14 years ago

First of all, thanks for the great software!

With Raki, I am able to browse my Pocket PC 2002. I've installed the syncekonnector using the package manager.

The process I have been following is like so:

I synce-serial-start

raki lights up and I get a connection. I am able to browse my pocket pc. Neat.

I choose configure pucker (name of my pocket pc)

I then try to check "appointments" and raki immediately crashes.

Before installing syncekonnector, it would tell me that the necessary plugin was not installed. What am I missing?

Thanks very much.

Also, I'm having trouble sifting through all the synceing options out there. What is the best and/or only option for syncing a windows CE device and kontact?

Thanks, Jerimiah

Report

neteng

14 years ago

Well i found the file locations configuration in RAKI that was not mentioned here. After setting the proper file locations sync SEEMS to work fine except only the addressbook is synchronized. No to-do list entries or appointments show up on the PDA although the sync dialog shows them being written.
The PDA is a dell Axim running pocketpc2003. Is my problem with RAKI or syncekonnector?

Report

neteng

14 years ago

Just as above I have everything installed and the connection works but when I try to configure the options in raki it says "No synchronizer found for Appointment". The same for all the others. I am using the latest Kanotix flavor of Debian.

Report

neteng

14 years ago

well using apt-get to reinstall syncekonnector allows me to configure the sync options of my device now but no matter what ones (or one) i select for sync, when I actually try to sync, Raki crashes. Here is the crash output.
dwolfe@NetengLT:~$ raki: ... init
raki: Creating PairEditorDialog
raki: PocketPCConnectorConfig::loadSettings
raki: Subscribing Events ...
kresources: ERROR: ManagerImpl::readResourceConfig: mFactory is 0. Did the app forget to call readConfig?
raki: ERROR: Received DCOP: resource added for unknown resource F6kN3ouEa6
raki: ... init
raki: Subscribing Contacts ...
raki: ... init
raki: Subscribing Todos ...
raki: SynCEDeviceKonnector::readSyncees()...
raki: SynCELocalKonnector::readSyncee()...
raki: SynCEDeviceKonnector::writeSyncees()...
raki: SynCELocalKonnector::writeSyncees()...
raki: SynCEDeviceKonnector::readSyncees()...
raki: Retrieving Contact from device: RRA-ID-03001dc1
raki: ID-Pair: KDEID: RRA-ID-03001dc1 DeviceID: RRA-ID-03001dc1
raki: Retrieving Contact from device: RRA-ID-05001d39
raki: ID-Pair: KDEID: RRA-ID-05001d39 DeviceID: RRA-ID-05001d39
raki: SynCELocalKonnector::readSyncee()...
KCrash: Application 'raki' crashing...

Report

neteng

14 years ago

This is the error on the console when i start raki from there.
kio (KMimeType): WARNING: KServiceType::offers : servicetype Raki/Synchronizer not found

I have found the .desktop files in /usr/share/services with all the other KDE .desktop files. any help would be appreciated.

Report

guydl

14 years ago

Hello,
I can compile now, I upgrade from unstable the kdepim and kitchensync.
But when I start a synchro raki crash.
Guy

Report

C

voc

14 years ago

Did you also configure the konnector in raki? Klick on the configure-button after selection one of the synchronization types
- Appointment,
- Contact, or
- Taks
and select the files the connector should sync with.

Report

guydl

14 years ago

Hello,

I use a debian etch.
I upgraded the distrib to kde3.5
I try to compile synceKonnector that is not available via apt
And I receive thes errors :
paireditorwidget.cpp: In member function 'void PairEditorWidget::setPair(KonnectorPair*)':
paireditorwidget.cpp:93: error: 'class KSync::SynCEKonnectorBase' has no member named 'initDefaultFilters'
paireditorwidget.cpp:104: error: 'class KSync::SynCEKonnectorBase' has no member named 'initDefaultFilters'
make[2]: *** [paireditorwidget.lo] Erreur 1
make[2]: quittant le répertoire « /home/guy/syncekonnector-0.3.2/librakikpimsync »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /home/guy/syncekonnector-0.3.2 »
make: *** [all] Erreur 2
guy@pcGDL:syncekonnector-0.3.2$

Can you help me ?

Report

LeXa

14 years ago

I have the same problem...

Report

Cypress

14 years ago

I successfully installed syncekonnector but when I start Multisynk I can't seem to find the two plugins required to help me sync: SynCE Konnector and Local Konnector. I there a special way to add them to Multisynk?

Report

C

voc

14 years ago

syncekonnector could not be used with multisynk anymore (at the moment). It is a plugin for raki, the "activesync-clone" in SynCE-KDE.
Start vdccm, start raki, connect your device, choose "Appointment", "Contact", and "Todo" in the device-configuration dialog of raki, configure all those synchronization types, and than try to sync.

Report

Cypress

14 years ago

It works now. Thanks. Great tool. I guess I'l purge my synce connect scripts now :) I really hope I'll see more features soon :)

Report

gauret

14 years ago

I've installed syncekonnector, but in the configure dialog I can't check Appointment, nor Contact, nor Todo, etc...
I always pops up a box with "No synchronizer found for Appointment"

Report

C

voc

14 years ago

You probably haven't installed the syncekonnector in the distribution-dependent kde directory tree.
If the install directory isn't choosen correctly, the *.desktop files are not found by kde and therefore kde didn't know anything about the plugin. Which distribution do you use?

Report

14 years ago

Initial version.

12345678910
product-maker Base: 4 x 5.0 Ratings
richlv
Jul 21 2009
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.3.2
updated Feb 22 2006
added Feb 22 2006
downloads 24h
0
mediaviews 24h 0
pageviews 24h 0
System Tags app software