Frescobaldi

Audio Apps

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

9
6 .6
Description:

Frescobaldi is a LilyPond sheet music editor. It aims to be powerful, yet lightweight and easy to use.

You can edit LilyPond documents and build and preview them with a mouse click. Clicking on notes in the PDF preview places the text cursor in the right place. A score wizard is provided to quickly setup a music score. There are editing tools to manipulate the rhythm, acticulations, lyrics hyphenation, etc.

Unlike version 1.2.0 the 2.0 versions do not need KDE4 anymore, but just Python and PyQt4.

When using the Windows installer, it might be necessary to install the MS VC 2008 runtime from
http://www.microsoft.com/download/en/details.aspx?id=29.
Last changelog:

5 years ago

Many new features and improvements. You also need to install `python-ly` from https://pypi.python.org/pypi/python-ly .

geoTrouvetout

11 years ago

I've just tested your ebuild. It just simply works !
Here are the steps I did :
created a frescobaldi directory under /usr/portage/media-sound
I then put the content of your ebuild in a file named frescobaldi-0.7.7.ebuild in this directory.
At this point I ran :
$ ebuild frescobaldi-0.7.7 manifest

I then created a file under /etc/portage/package.keywords named frescobaldi with a simple line : media-sound/frescobaldi

The emerge frescobaldi went then fine and I can now use this great app !
Thanks a lot for your help !

Report

m5acb

11 years ago

I thought KDE apps would run under gnome, but it appears not.

for frescobaldi 0.7.7: I got the error
/bin/sh: KDE4_MEINPROC_EXECUTABLE-NOTFOUND: not found

for frescobaldi 0.7.6: i got the error

-- Installing: /usr/bin/frescobaldi
CMake Error at cmake_install.cmake:36 (FILE):
file INSTALL cannot copy file
"/home/andrew/Downloads/frescobaldi/frescobaldi-0.7.6/frescobaldi" to
"/usr/bin/frescobaldi".


make: *** [install] Error 1

So I did sudo make which reported:

[ 37%] Built target bytecompile_python
[ 92%] Built target lilypond_pngs
[100%] Built target translations

without an error.

However I cannot find frescobaldi executable in /usr/bin/

Please help because frescobaldi looks really useful for our choir mistress.

Thanks.

Report

C

wbsoft

11 years ago

Regarding GNOME: Frescobaldi should run under GNOME, it just needs kdelibs, kdebase and kdegraphics (for Okular, the PDF widget) installed and PyKDE4 (the Python bindings for KDE4, because it is written in Python).

Report

C

wbsoft

11 years ago

meinproc4 builds the help file cache.

Try to determine which package is needed by apt-file search meinproc4 and install that package OR just use the ubuntu package by Chris Snyder at
https://launchpad.net/~frescobaldi/+archive/ppa

Chris Snyder created (K)Ubuntu packages for both Intrepid (8.10) and Jaunty (9.04).

Report

m5acb

11 years ago

I could not get the ubuntu package to work on Intrepid. Despite loading the repository info and the authenticaion, Frescobaldi did not appear in the list of available application available in synaptic.

However I did manage to install it manually.

Thanks.

Report

Manolete

11 years ago

Any Debian (ish) packages for those ignorant musicians who barely can use a computer?

Thanks for this nice app, :).

Report

C

wbsoft

11 years ago

There are now (K)Ubuntu packages at
https://launchpad.net/~frescobaldi/+archive/ppa

Report

C

wbsoft

11 years ago

Frescobaldi will be in KUbuntu Jaunty (9.04)

Report

terjemjelde

11 years ago

I really like this app. It makes it so much easier to edit lilypond files.

However, I can't get frescobaldi to save the preferences I specify under "Settings | Configure". Nor does it remember my "View"-preferences (e.g. Linenumbers, Quick insert etc). Am I doing something wrong or is this not implemented yet? I notice that some things, like "Settings | Show Path" is saved under ~/.kde4/share/config/frescobaldirc.

I am using OpenSUSE 11.1, KDE4.1.

Report

phroddy

11 years ago

Dear Terje Mjelde
I have installed Frescobaldi on my
opensuse system, having downloaded the gcc
compiler and the related C++ compiler. Also the Python files. However, as a
complete novice to linux, I haven't a
clue how to get Frescobaldi to run.
Do I have to run python first or run
it from the terminal. I tried ./frescobaldi but got the message I didn't
have the correct privelege.
I normally use Windows XP
If you could give me a clue I will be
very grateful.
Yours sincerely,
Frederick Dennis.
ps Wilbert Berendson says to "fire up"
Frescobaldi from "Utilities". This doesn't work in the least.

Report

phroddy

11 years ago

My latest error message is:
/bin/sh: KDE4_MEINPROC_EXECUTABLE-NOTFOUND:
command not found.
I'm using OpenSuSe and trying to install
frescobaldi-0.7.8
I've tried loading KDE4libraries and
different versions.
Is there any way of loading meinproc4?
Thanks for your attention.
Frescobaldiless

Report

C

wbsoft

11 years ago

Thank you for your compliments.

The saving of the settings you describe are indeed not implemented yet. Some are settings that are not global to Frescobaldi, but unique for every opened document.

I have not yet figured out how to save those settings.

But also it seems some settings in the editor component config pages are not saved. That would be a bug on Frescobaldi's part. Thanks again for your report!

Report

C

wbsoft

11 years ago

Fixed in SVN. Now Frescobaldi should save user's settings. Thanks again for reporting.

Report

Boccaccio

11 years ago

Will there be a gentoo ebuild made available like for lilykde?

Thanks in advance!

Report

C

wbsoft

11 years ago

I finally got around creating a Gentoo ebuild:

http://lilykde.googlecode.com/svn/trunk/frescobaldi/gentoo/

Put it in your overlay in the media-sound category and name it frescobaldi-0.7.7.ebuild

then ebuild frescobaldi-0.7.7.ebuild digest and then emerge frescobaldi.

Report

C

wbsoft

11 years ago

Unfortunately, after many years I just switched my home system from Gentoo to Kubuntu. But I'll try to create one!

Report

drvirgilio

11 years ago

I get this when I do make.

Quote: [ 29%] Generating articulation_longfermata.png
GNU LilyPond 2.10.33
Processing `builddir/pics/articulation_longfermata.ly'
Parsing...lilypond: ports.c:978: scm_fill_input: Assertion `pt->read_pos == pt->read_end' failed.
/bin/sh: line 1: 29900 Aborted lilypond -ddelete-intermediate-files --png -dpixmap-format=pngalpha -o builddir/pics/temp_articulation_longfermata builddir/pics/articulation_longfermata.ly
make[2]: *** [pics/articulation_longfermata.png] Error 134
make[1]: *** [pics/CMakeFiles/lilypond_pngs.dir/all] Error 2
make: *** [all] Error 2

I'm running Archlinux on an AMD 64. Any ideas?

Report

C

wbsoft

11 years ago

Your best bet would probably be upgrade LilyPond to 2.12.0

But I should really release a package with the LilyPond-generated icons prebuilt! I will try in the short future.

Report

drvirgilio

11 years ago

Thanks. I got it working now.

Report

C

wbsoft

11 years ago

So, next release (0.7.3 or 0.8.0 don't know yet) will be easier to install (no need to build the Lily icons, those will be prebuilt in the release tarballs).

Report

C

wbsoft

11 years ago

but LilyPond 2.10.33 should work. It probably has something todo with the 64bit compiled version you use. And that could have been fixed in the recent stable 2.12 releases.

Report

dovidhalevi

11 years ago

raceback (most recent call last):
File "/usr/local/bin/frescobaldi", line 42, in <module>
license, copyright, text, homepage, bugs)
TypeError: argument 1 of KAboutData() has an invalid type

Report

C

wbsoft

11 years ago

Please update SIP (python-sip4) to the most recent version (I believe 4.7.7). And also PyQt4 and PyKDE4 should be recent versions.

Report

gecko

11 years ago

Hey, nice work, is there also any possability to export it to MusixTeX or some other thing I can include in LaTeX?

Report

C

wbsoft

11 years ago

If there would be an utility that exports LilyPond to MusixTex, Frescobaldi could provide an easy to use GUI for it.

But you can already use LilyPond from within LaTeX, using lilypond-book. See the lilypond documentation.

Report

5 years ago

Many new features and improvements. You also need to install `python-ly` from https://pypi.python.org/pypi/python-ly .

12345678910
14
product-maker emw Jun 25 2015 9 excellent
product-maker pondogor Sep 14 2012 3 bad
product-maker fri Dec 27 2011 9 excellent
product-maker flyingsheep Dec 12 2010 9 excellent
product-maker jaegerschnitzel Oct 14 2010 9 excellent
Be the first to comment
SeeLook
Jan 18 2012
JMairboeck
Nov 26 2011
brrtkr
Jan 13 2011
flyingsheep
Dec 12 2010
plcl
Sep 11 2010
jaegerschnitzel
May 15 2009
geoTrouvetout
Mar 06 2009
emw
Feb 22 2009
giuped
Feb 21 2009
File (click to download) Version Description PackagetypeArchitectureRelease Channel Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
2.18
updated Mar 08 2015
added Dec 26 2008
downloads 24h
0
mediaviews 24h 0
pageviews 24h 3