Apollon

Network

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

1
5.0
Available as/for: -
Description:

Apollon - the greek god of music, mp3s, and videos! Apollon is a KDE-based client for the p2p-protocol giFT (OpenFT, FastTrack(Kazaa!), Gnutella, OpenNap) It is very userfriendly, intuitively, offers an inline Mediaplayer for previews of downloaded files, etc etc


For further questions and support please contact us either on
apollon-devel@lists.sourceforge.net
or irc.freenode.net#apollon.
That little forum below is not a help/support/bug-forum, imho.
Last changelog:

15 years ago

8 May 2005
- added icons for Ares.
- improvements of the search page
- all in one installer contains Ares plugin as well
- fixed some translation filenames.

14.12.04:
Updated the all-in-one installer.
Contains now the latest versions of:
giFT: 0.11.8.1
OpenFT: 0.2.1.5
Gnutella: 0.0.10rc1
FastTrack: 0.8.8

13.10.04:
fixed several QT 3.2/3.3 issues.
updated french and serbian translation.
significantly improved first run wizard. Installs now all available plugins automatically (and not only OpenFT).

01.10.04:
Again a bugfix-release of the installer. Lots of important bugfixes!

29.09.04:
Bugfix-release of the all-in-one installer. Fixes compile-errors with mising QT libraries.

26.09.04
Apollon 1.0
===========

- Apollon connects to the chat only when desired.

- "search for more sources" changes the icon to express the action

- fixed some untranslatable strings.

- ctrl-w and Esc go to the right tab-page in the search-page.

- Apollon should be compatible to KDE versions installed after apollon now.

- added helenic, norwegian, danish, russian translations.

- NEW FEATURE: added chat-support for apollon-users
* nick colouring and highlighting
* tab-nick-completion
* popup-notification if your nick is mentioned

- added the choice for "apollon-progressbars" and "KDE-progressbars"

- replaced the progressbars with real ones.


May 15 2004:
Apollon 0.9.4
=============

- added brazil translation

- some changes to prepare apollon for autopackage.

- apollon is ready for the use with unsermake

- files already in progress appear in your searchresults as selected for downloading

- improved tooltip in the search page.

- enable/disable docking. docking ready for GNOME-uses who have the kdesystrayproxy installed

- toolbar added for transfer page

stampede2

16 years ago

The code for Brazilian Portuguese is pt_BR, and not pt_br (it's case-sensitive). Therefore, the Brazilian Portuguese translation currently is not working.

Report

LTD602

16 years ago

How do I run the all-in-one-installer?

It's the first time I've encountered a .run file. What is the command?

Thanks, looks like a great p2p program.

Report

LTD602

16 years ago

Ok, I just made it an executable and it began the arkollon process.

BUT, I got this error:

checking for lt_dlopen in -lltdl... no
* configure: error:
* *** Couldn't find ltdl library. If it is installed in a non-standard
* *** location, please supply --with-ltdl=DIR on the configure command line,
* *** where `DIR' is the prefix where ltdl is installed (such as /usr,
* *** /usr/local, or /usr/pkg). If that doesn't work, check config.log.
*
***** Return value 1

Where can I get ltdl? I don't seem to haev it. I'm running Madnrake10.

Report

C

mkoebele

16 years ago

isn't ltdl libtool?

try installing libtool.

Report

daydreamer

16 years ago

same problem..
where can I find this lib ?

Report

unbedingtanonym

16 years ago

Hello could somebody do this again for a real newbie?

1. where do I have to put the installer?
2. How do I have to open it( As root or normal or with a Terminal?)

Thanks

Report

C

mkoebele

16 years ago

sh apollon-installer-0.6.run

or:

chmod +x apollon-installer-0.6.run
./apollon-installer-0.6.run


Martin

Report

nsteeves

16 years ago

QT-3.3.3
KDE-3.3.1

In file included from apollon.all_cpp.cpp:26:
chatline.h: In constructor `chatLine::chatLine(QWidget*, const char*)':
chatline.h:46: warning: `chatLine::m_textChanged' will be initialized after
chatline.h:45: warning: `int chatLine::m_matchIndex'
chatline.cpp:26: warning: when initialized here
chatline.cpp: In member function `virtual bool chatLine::event(QEvent*)':
chatline.cpp:102: warning: comparison between signed and unsigned integer
expressions
In file included from firstrun.cpp:30,
from apollon.all_cpp.cpp:28:
firstrun.ui.h:20:29: libgift/libgift.h: No such file or directory
firstrun.ui.h:21:26: libgift/conf.h: No such file or directory
In file included from preferences.cpp:33,
from apollon.all_cpp.cpp:29:
preferences.ui.h:20:29: libgift/libgift.h: No such file or directory
preferences.ui.h:21:26: libgift/conf.h: No such file or directory
In file included from preferences.cpp:33,
from apollon.all_cpp.cpp:29:
preferences.ui.h: In member function `virtual void
ApollonPreferencesDialog::readGiftConfig(bool)':
preferences.ui.h:92: error: `config_new_ex' undeclared (first use this
function)
preferences.ui.h:94: error: `config_get_int' undeclared (first use this
function)
preferences.ui.h:96: error: `config_get_str' undeclared (first use this
function)
preferences.ui.h:156: error: `config_free' undeclared (first use this function)
preferences.ui.h: In member function `virtual void
ApollonPreferencesDialog::saveGiftConfig()':
preferences.ui.h:258: error: `config_new_ex' undeclared (first use this
function)
preferences.ui.h:261: error: `config_set_str' undeclared (first use this
function)
preferences.ui.h:262: error: `config_set_int' undeclared (first use this
function)
preferences.ui.h:328: error: `config_write' undeclared (first use this
function)
preferences.ui.h:329: error: `config_free' undeclared (first use this function)
make[3]: *** [apollon.all_cpp.o] Error 1
make[3]: Leaving directory `/home/media/misc/work/ShawNET/ports/apollon/work/src/apollon-1.0.1/apollon'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/media/misc/work/ShawNET/ports/apollon/work/src/apollon-1.0.1/apollon'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/media/misc/work/ShawNET/ports/apollon/work/src/apollon-1.0.1'
make: *** [all] Error 2

Report

C

mkoebele

16 years ago

you don't have giFT installed.
I suggest you download the all-in-one installer, takes care of everything.

Report

rodgerSan

16 years ago

hi,
when i tried to install it i have this error:
make[3]: Entering directory `/home/rodgersan/tmp/selfgz14886/apollon-1.0/apollon'
/usr/lib/qt3//bin/uic -L /usr/lib/kde3/plugins/designer -nounload -o firstrun.h ./firstrun.ui
* uic: File generated with too recent version of Qt Designer (3.3 vs. 3.2.3)
* make[3]: *** [firstrun.h] Erreur 1
make[3]: Leaving directory `/home/rodgersan/tmp/selfgz14886/apollon-1.0/apollon'
make[2]: Leaving directory `/home/rodgersan/tmp/selfgz14886/apollon-1.0/apollon'
* make[2]: *** [all-recursive] Erreur 1
* make[1]: *** [all-recursive] Erreur 1
make[1]: Leaving directory `/home/rodgersan/tmp/selfgz14886/apollon-1.0'
* make: *** [all] Erreur 2
***** Return value 2

i don't understand...did it come because my qtdesign version is more recent and how can i resolve that?

cheers

Report

C

mkoebele

16 years ago

no, it's the other way: your qt version is older ;)

I'm gonna release apollon 1.0.1 sometime next week which has this issue fixed.

Martin

Report

rodgerSan

16 years ago

oooopss :-) thanks a lot for your quick answer

Report

peispud

16 years ago

I've also tried to install this on both Mandrake 10 and 10.1 . The all in one installer produced a whole slew of errors . While almost all or the RPMs installed fine and gift will run on both 10 and 10.1 , it will not connect . With Mandrake 10 Apollon started up fine , but with 10.1 it promptly crashes . Unless there is some kind of all in one RPM or some one that knows how to get this monster working with Mandrake I'm throwing in the towel :(

Report

jox

16 years ago

first of all thanks for help last time.
apollo and plugins installed fine but when i run it fasttrack and other plugins try to connect but nothing happens. the chat program works also fine. i alread tried by stopping my firewall but same problem.

who could help ??

Report

ragille

16 years ago

apollon-installer should be startet from X/KDE as regular user.

Otherwise the installer "hangs" while waiting for X...

Report

fake

16 years ago

Last time I've tried Apollon, I couldn't find an OpenNap plugin. Is it available now? I really like to get rid of Lopster as soon as possible...

Report

Ekardnam

16 years ago

Comes in several languages. So far:

Brazilian (pt_br)
Danish
Dutch
English
Finnish
French
German
Greek
Hebrew
Italian
Norwegian
Polish
Russian
Spanish

Huh? No Swedish?
Well, I prefer to use English, but... if there are that many languages, but not Swedish...!

I could (I think) try to translate it to Swedish. It would be helpful if you tell me how, since Im not a programmer/understans that I'm supposed to change.

Report

fab

16 years ago

Please contact the KDE Quality Team. They should be able to help you get started.

http://quality.kde.org/
kde-quality@kde.org

Cheers'

Fab

Report

jox

16 years ago

hi
i have a problem while compiling apollon with the installer-0.5
i get the following message in the log-file:

checking for Qt... libraries /usr/lib/qt3/lib, headers /usr/lib/qt3/include using -mt
checking for moc... /usr/lib/qt3/bin/moc
checking for uic... /usr/lib/qt3/bin/uic
checking whether uic supports -L ... yes
checking whether uic supports -nounload ... yes
checking if Qt needs -ljpeg... no
checking for rpath... yes
* configure: error:
* in the prefix, you've chosen, are no KDE headers installed. This will fail.
* So, check this please and use another prefix!
***** Return value 1


just up to that point everything works fine.
is something in my installation missing ???

thanks for help...

Jox...

Report

C

mkoebele

16 years ago

yes, something is missing. Actually, the error message tells you what is missing. Install KDE headers, which means: install the packages kdelibs-devel and kdebase-devel.

Martin

Report

anderslund

16 years ago

Please get rid of the puild in player. It can only handle a very limited set of mimetypes, you should just let the user settings decide which app to use for previews.

Report

oshogg

16 years ago

Congratulations on 1.0!!

Apollon is one of the best P2P apps ever, on any platform or OS.

cheers,
Osho

Report

psch

16 years ago

Hi,
when runnig the latest Arkollon installer, the make proces seems to take forever ?
So I need to kill the proces without any visible reason ?

What could be the problem here ?

SuSE 9.1
KDE 3.3

Report

ushohet

16 years ago

I saw the same problem. I decided to run "./apollon-installer-0.5.run --target NewDirectory"

It failed with: Warning: an error occured running make. Check the .arkcomp-log file created in your home directory"

The log showed:
make[1]: *** No rule to make target `/usr/lib/qt3/mkspecs/default/qmake.conf', needed by `Makefile'. Stop.

Not all systems have QT installed in /usr/lib/qt3

After I removed all Makefiles in arkollon-0.4 directory and executed "qmake arkollon.pro" - the install.sh started properly.

HTH,
Uri

Report

C

mkoebele

16 years ago

what is "forever" for you?

compiling needs some time.

Martin

Report

15 years ago

8 May 2005
- added icons for Ares.
- improvements of the search page
- all in one installer contains Ares plugin as well
- fixed some translation filenames.

14.12.04:
Updated the all-in-one installer.
Contains now the latest versions of:
giFT: 0.11.8.1
OpenFT: 0.2.1.5
Gnutella: 0.0.10rc1
FastTrack: 0.8.8

13.10.04:
fixed several QT 3.2/3.3 issues.
updated french and serbian translation.
significantly improved first run wizard. Installs now all available plugins automatically (and not only OpenFT).

01.10.04:
Again a bugfix-release of the installer. Lots of important bugfixes!

29.09.04:
Bugfix-release of the all-in-one installer. Fixes compile-errors with mising QT libraries.

26.09.04
Apollon 1.0
===========

- Apollon connects to the chat only when desired.

- "search for more sources" changes the icon to express the action

- fixed some untranslatable strings.

- ctrl-w and Esc go to the right tab-page in the search-page.

- Apollon should be compatible to KDE versions installed after apollon now.

- added helenic, norwegian, danish, russian translations.

- NEW FEATURE: added chat-support for apollon-users
* nick colouring and highlighting
* tab-nick-completion
* popup-notification if your nick is mentioned

- added the choice for "apollon-progressbars" and "KDE-progressbars"

- replaced the progressbars with real ones.


May 15 2004:
Apollon 0.9.4
=============

- added brazil translation

- some changes to prepare apollon for autopackage.

- apollon is ready for the use with unsermake

- files already in progress appear in your searchresults as selected for downloading

- improved tooltip in the search page.

- enable/disable docking. docking ready for GNOME-uses who have the kdesystrayproxy installed

- toolbar added for transfer page

12345678910
Be the first to comment
deuteros
May 12 2010
File (click to download) Version Description PackagetypeArchitectureRelease ChannelDevices Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
1.0.2.1
updated May 08 2005
added Jan 05 2004
downloads 24h
0
mediaviews 24h 0
pageviews 24h 1
System Tags app software