Gmail Feed

Plasma 5 Applets

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

4
7.7
Available as/for: -
Description:

Gmail Feed is a plasmoid for Plasma 5. It provides a list of your unread emails from your Gmail inbox. You also get notified when you receive new messages.

paulikos

4 years ago

It's solved. It was a dev package (knotification) missing. Once more thanks for all!

Report

paulikos

4 years ago

Thanks for your help and patient!

Report

adwmau

4 years ago

I am getting this error after compiling and installing

Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.gmailfeed/contents/ui/main.qml:24:1: module "org.kde.plasma.private.gmailfeed" is not installed

Do you know how to fix this?

Report

ybeltukov

4 years ago

Please find a simple ebiuld to install your nice plasmoid in Gentoo:
https://gist.github.com/ybeltukov/f0633fecda3ddc30e8e2be06904b4ac8

Report

ybeltukov

4 years ago

Now the official ebuild was added as "kde-misc/
gmailfeed".

Report

mixedwrist

4 years ago

Any chance on bringing in multiple accounts check and/or execute custom command instead just opening inbox or the project is dead? (Asking for kaccounts version)

Report

Loacoon

4 years ago

As the title sais, in each update, the applet asks again for my email and password...

Report

Loacoon

4 years ago

Up?

Report

C

anthon38

4 years ago

You need to have kwalletd5 running

Report

Loacoon

4 years ago

Ok... too bad...

Report

aschkolnik

4 years ago

Hi

When I move my mouse over the Gmail Feed icon, I see the message:
5 unread messages

However, I do not see the subjects.
If I am not mistaken, the subjects are displayed when a new message arrives, but not after.
Is this the intended behavior ?
I would like to see the subjects every time I move the mouse over the icon.
Is there any way to make that happen ?

Report

9

rosenrot

4 years ago

How to login, if I use the Two-step verification?

Report

terrifyingfungus

4 years ago

You need to click the link bellow and set up an app specific password.
https://security.google.com/settings/security/apppasswords

Report

mathojojo

4 years ago

Installed via ubuntu repositories, but does not show up in the plasmoid list...

strange !

Report

trekjunky

4 years ago

I go to the download widgets and choose Gmail Feed and click Install. It doesn't appear in the list. I reboot and it says it is not installed, so I reinstall it, it asks to overwrite the file, I say yes, and it appears to install, but it doesn't show up in the list. I can't figure this out. Please help.

Report

trekjunky

4 years ago

Also, I have Opensuse Leap 42.1, plasma 5...

Report

C

anthon38

4 years ago

You can't install it with GetHotNewStuff, because it works only with purely scripted plasmoids. (I know, it's misleading but there is only one category available for Plasma 5 plasmoids)
You have to install it manually. (ie download the source, extract, go in the directory, mkdir build, cd build, cmake .. -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DLIB_INSTALL_DIR=lib -DKDE_INSTALL_USE_QT_SYS_PATHS=ON, then make and make install)

Report

demonFudgePies

4 years ago

I install the thing, and the icon appears, but when I click on it, it says

Error loading QML file: file:///usr/local/share/plasma/plasmoids/org.kde.plasma.gmailfeed/contents/ui/main.qml:24:1: module "org.kde.plasma.private.gmailfeed" is not installed

Any idea how I might fix this?

Report

krem1234

4 years ago

Hi, I followed these instructions and rebooted, but the plasmoid is still not showing up in my list. I did receive an error when running cmake and had to use the following:

git clone git://anongit.kde.org/extra-cmake-modules
cd extra-cmake-modules
mkdir build && cd build
cmake ..
make && sudo make install

Not sure if that's why I can't get it to work? Thanks for any help, I would love to use this plasmoid.

Report

trekjunky

4 years ago

It worked. Thanks so much!!!!

Report

trekjunky

4 years ago

It worked. Thanks so much!!!!

Report

naughtypine

4 years ago

Seconded. Also on Leap. I really miss this widget.

Report

dshrek

5 years ago

Since a couple of days the applet doesn't function anymore. When I click on the applet I get the message: "Der Zugriff auf das Netzwerk ist nicht gestattet" (access to network is not permitted).
Unfortunately I have no idea what has happened as the applet always worked fine before and I am not aware of any recent changes/updates.

Report

dshrek

5 years ago

Sorry, that problem was on my side. None of my applets had a network connection, though everything else using network worked fine. After reinstalling network-manager, purging plasma-widget-networkmanagement or after today's kernel update, everything works fine (not sure which of the three solved the problem)...

Report

trekjunky

5 years ago

I had to reinstall my root partition and now, when I add your plasmoid, it says it installed, but it doesn't show up in the plasmoid list. Please help?

Report

12345678910
115
product-maker shaeda Aug 15 2019 1 ugh
Sadly, looks like it no longer works. :(
product-maker emplate430 May 19 2018 9 excellent
TY!
product-maker tepca Nov 09 2016 9 excellent
product-maker dubious Nov 09 2016 9 excellent
product-maker izzzy Nov 05 2016 9 excellent
product-maker schnelle Jan 16 2016 9 excellent
product-maker rosenrot Sep 18 2015 9 excellent
product-maker jarod82 May 16 2015 9 excellent
product-maker roctheme May 07 2015 9 excellent
product-maker pyrforos Apr 29 2015 9 excellent
product-maker fatino Apr 28 2015 9 excellent
product-maker janet Mar 27 2015 9 excellent
product-maker frag Dec 27 2014 9 excellent
product-maker jarkamirov Dec 20 2014 9 excellent
product-maker pjhalsli Dec 20 2014 9 excellent
product-maker ithemaster Dec 20 2014 9 excellent
Be the first to comment
bialyikar
Oct 24 2020
doczilaci
Jan 03 2019
x-varlesh-x
Apr 05 2018
aschkolnik
May 10 2016
x-varlesh-x
May 13 2018
File (click to download) Version Description Devices Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
1 Plings
0 Affiliates
Details
license
version
1.1
updated Mar 23 2015
added Dec 20 2014
downloads 24h
8
mediaviews 24h 0
pageviews 24h 9