QuickLauncher Applet

Plasma 4 Extensions

Source (link to git-repo or to original if based on someone elses unmodified work): Add the source-code for this project on opencode.net

5
5 .3
Description:

Reimplements the quicklaunch applet present in kde3.5.

Features:
- Add icons by specify a .desktop file
- Add icons by dragging .desktop files from other locations (desktop and panel doesn't seem to work, KDE4 issue?)
- Rearrange icons by dragging them in place
- Configurable number of rows
- Configurable number of visible icons.
Last changelog:

12 years ago

0.5
Support for vertical panels
Bugfixes

0.4
Working with KDE 4.1

0.3
Added initial support for hiding icons.
Added configure option to select number of visible icons

0.2.1
Removed the unwanted double-click config obeyance

0.2
Added Drag'n drop functionality.

0.1
Initial version

oxi

12 years ago

Kubuntu Intrepid 8.10 x86, version 0.5:
http://www.2shared.com/file/4318619/c5ad9d92/plasma-applet-quicklauncher_05-1_i386.html

Kubuntu Intrepid 8.10 x86_64, version 0.5:
http://www.2shared.com/file/4318634/892a83ad/plasma-applet-quicklauncher_05-1_amd64.html

Report

realflash

11 years ago

Those links don't work - the page in question makes it look like you ought to be able to download it, but there is no link on the page, and no download pops up. Can someone post them to a real website please?

Report

oxi

11 years ago

Sorry, I should have chosen a better host I guess. It's not too apparent where the download link is indeed...

Look at the bottom right corner in the blue box, where it says: "Save file to your PC: click here". There it is.

Report

lucher

12 years ago

My impression is that you have to rework the widget's lyout a little:

(1) It should cover the same space as the default-size-icons. In my impression, the Quick launch icons cover the whole height of a panel. Can you change this (making the icons a little smller, but fitting it better to the icons next to it)

(2) I started using an autofitting panel, i.e. it resizes itself according to the number of taskbar items. When switching desktops, the quicklaunch plasmoid flickers and adjusts the margin between its icons depending on panel size. This should not happen.

PS: Is it possible to reuse the "tooltips" and the configuration dialogs of "usual" plasma panel icons?

Best regards

Report

joth666

12 years ago

The 0.5 is the first version that remembers the icons I've added to it,so now it's great to have!

Just two suggestions for future versions though (which you've probably already heard...)

1. Make it possible to just browse the list of what's in kickoff instead of having to locate the .desktop file.
2. Since the icons can be rather small, it might be a good idea to have a popup if the mouse hover over the icon. Just like it works if you have a ordinary icon in the panel.

Report

Robbi1987

12 years ago

i installed it on 8.10 and nothing happen in the mini program list. I liked it in 8.04 should be updated for Intrepid!

Report

kappa01

12 years ago

On 8.10 Install.sh aborts as follows:
[build]$make
[ 25%] Generating ui_quicklauncherAdd.h
Generating quicklauncher.moc
[ 50%] Generating ui_quicklauncherConfig.h
Scanning dependencies of target plasma_applet_quicklauncher
[ 75%] Building CXX object CMakeFiles/plasma_applet_quicklauncher.dir/plasma_applet_quicklauncher_automoc.o
[100%] Building CXX object CMakeFiles/plasma_applet_quicklauncher.dir/quicklauncher.o
/usr/share/plasma-applet-quicklauncher-0.5/src/quicklauncher.cpp:26:35: error: kworkspace/kworkspace.h: No such file or directory
make[2]: *** [CMakeFiles/plasma_applet_quicklauncher.dir/quicklauncher.o] Error1
make[1]: *** [CMakeFiles/plasma_applet_quicklauncher.dir/all] Error 2
make: *** [all] Error 2
[build]$

Report

Filozof

12 years ago

"CMake Error: The source directory "/home/jakub/Dokumenty/programy/quicklauncher/plasma-applet-quicklauncher-0.5/src" does not appear to contain CMakeLists.txt."

On Kubuntu 8.10. Is it a fault of script or my computer?

Report

C

svenstorp

12 years ago

Added support for vertical panels. Also fixed the nasty bug where icons didn't get saved as they should.

If you do distribution specific packages please let me know, so I can add them!

Report

sisqonrw

12 years ago

hi i cannot install it. see:

[URL=http://img255.imageshack.us/my.php?image=quickga7.png][IMG]http://img255.imageshack.us/img255/1772/quickga7.th.png[/IMG][/URL][URL=http://g.imageshack.us/thpix.php][IMG]http://img255.imageshack.us/images/thpix.gif[/IMG][/URL]

i am using Kubuntu (KDE 4) 8.10 (Intrepid Ibex)

Report

oxi

12 years ago

The kubuntu package didn't work for me. It was installing the files to incorrect paths in my system. So I made a new one. This one works for me on Kubuntu 8.10 Intrepid x86. Hope it helps someone else.

http://www.2shared.com/file/4225845/c564795e/plasma-applet-quicklauncher_04-1_i386.html

Report

kevin79

12 years ago

WHere did you have to move the files to? Which files? I'm running 64bit so I can't use your deb but I would really like to get this working.

Report

oxi

12 years ago

I don't quite remember where I moved the files. However, I've just added a new package for version 0.5, for x86_64 too. Hope it helps.

Report

iconoclast88

12 years ago

I got This object could not be created on hardy kubuntu after installing the plasma-applet-quicklauncher_0.4-1_i386.deb package. Not sure what to do from here.

Report

smihael

12 years ago

I (mihael Simonič) made Debian amd64 package for this great plasmoid.

You can found it here:
http://smihael.bplaced.net/downloads/plasma-applet-quicklauncher_0.4-1_amd64.deb

Report

holodeck

12 years ago

If you want to compile this on Kubuntu Intrepid 8.10, you will need some dependencies. To spare people from googling for every single missing file, this is what you have to install:

sudo apt-get install kdelibs5-dev libplasma-dev kdebase-workspace-dev

Report

wmg

12 years ago

After rebooting my computer all my icons are lost from the plasmoid. I read somewhere in the comments that the icons are only saved when you remove an icon from the quick launcher.
But how do I remove an icon? I cannot find any option to remove one. And does that really solve the problem that the added icons are not saved?

Report

ororo

12 years ago

Same problem here.
Please somebody help us!

Using Kubuntu 8.10 Intrepid and quicklauncher 0.4-1

Where does quicklauncher store the paths of the icons? Thank you!

Report

BSDKaffee

12 years ago

A FreeBSD port has been created for this plasmoid: deskutils/plasma-applet-quicklauncher

Report

devel0per

12 years ago

ebuild is here - http://sonylaptoptools.sourceforge.net/ebuilds/quicklauncher-0.4.ebuild

Report

cfigura

12 years ago

I've just upgraded from hardy to intrepid beta, and am really working with KDE4 for the first time. I'd like to try out the quicklauncher - that's a big missing piece from the KDE4 panel, but I'm having problems. The hardy package installed, but doesn't show up on the 'add widget'. And I can't build from source. I get the following feedback on running the installer:

Quote:
-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
CMake Error at /usr/share/cmake-2.6/Modules/FindKDE4.cmake:72 (MESSAGE):
ERROR: cmake/modules/FindKDE4Internal.cmake not found in
/home/cfigura/.kde/share/apps;/usr/share/kubuntu-default-settings/kde4-profile/default/share/apps;/usr/share/kde4/apps
Call Stack (most recent call first):
CMakeLists.txt:3 (find_package)

CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present. A line of code such as

cmake_minimum_required(VERSION 2.6)

should be added at the top of the file. The version specified may be lower
if you wish to support older CMake versions for this project. For more
information run "cmake --help-policy CMP0000".
This warning is for project developers. Use -Wno-dev to suppress it.

-- Configuring done
make: *** No rule to make target `clean'. Stop.
make: *** No targets specified and no makefile found. Stop.
make: *** No rule to make target `install'. Stop.


Does anyone have any ideas? Help?

Report

Xenos

12 years ago

You need the kdelibs5-dev package.

Report

cfigura

12 years ago

Thanks! That and the kdebase-workspace-dev. So it's successfully built, and says that it installed to
Quote:
-- Install configuration: "Debugfull"
-- Installing: /lib/kde4/plasma_applet_quicklauncher.so
-- Installing: /share/kde4/services/plasma-applet-quicklauncher.desktop


Now I can't get it to add to my widget list! I go to 'add widget -> install new widgets -> install from file -> plasmoid: Native plasma widget'. I've tried looking in the install directories, nothing comes up. Any thoughts on this?

Report

Xenos

12 years ago

Yes, i got the same problem:)

I dont know why, but the the install.sh seems to use a wrong path on kubuntu. Copy both files to

"/usr/share/kde4/services/plasma-applet-quicklauncher.desktop"

and

"/usr/lib/kde4/plasma_applet_quicklauncher.so"

otherwise i can give you my compiled package (kubuntu 8.10)

Report

powiewiatru

12 years ago

Hello,

this pasmoid is great but I've encountered on a little inconvenience yesterday. Namely, I got fatal error and all my beautiful icons gone to hell. Unfortunately I wasn't able to restore it. So my question is:
where are the preferences kept?
Is there any possibility to restore them?

cheers!

Report

12 years ago

0.5
Support for vertical panels
Bugfixes

0.4
Working with KDE 4.1

0.3
Added initial support for hiding icons.
Added configure option to select number of visible icons

0.2.1
Removed the unwanted double-click config obeyance

0.2
Added Drag'n drop functionality.

0.1
Initial version

12345678910
11
product-maker Sweyn78 Aug 27 2012 9 excellent
product-maker joseexposito89 Aug 30 2011 3 bad
Be the first to comment
panoptus
May 14 2010
devport
Dec 09 2009
Timslin
Aug 23 2009
leandro
Mar 05 2009
jeykey
Feb 08 2009
File (click to download) Version Description Downloads Date Filesize DL OCS-Install MD5SUM
*Needs pling-store or ocs-url to install things
Pling
0 Affiliates
Details
license
version
0.5
updated Nov 15 2008
added Mar 30 2008
downloads 24h
0
mediaviews 24h 0
pageviews 24h 3