This is what I wanted for GTK apps ! - Sep 03 2010
This is the error message :

-- The C compiler identification is GNU
-- The CXX compiler identification is GNU
-- Check for working C compiler: /usr/bin/gcc
-- Check for working C compiler: /usr/bin/gcc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so
-- Looking for XOpenDisplay in /usr/lib/libX11.so;/usr/lib/libXext.so - found
-- Looking for gethostbyname
-- Looking for gethostbyname - found
-- Looking for connect
-- Looking for connect - found
-- Looking for remove
-- Looking for remove - found
-- Looking for shmat
-- Looking for shmat - found
-- Looking for IceConnectionNumber in ICE
-- Looking for IceConnectionNumber in ICE - found
-- Found X11: /usr/lib/libX11.so
-- Looking for include files CMAKE_HAVE_PTHREAD_H
-- Looking for include files CMAKE_HAVE_PTHREAD_H - found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
CMake Error at CMakeLists.txt:43 (message):
ERROR: Failed to detemine Qt3 plugins folder. Please pass
-DQT_PLUGINS_DIR=<folder> to cmake


INFO: Defaulting to reading KDE4 settings if KDE_SESSION_VERSION is not set
-- Configuring incomplete, errors occurred! - Sep 02 2010
Hello !

I used QtCurve in Mandriva so with my new Fedora 13 LXDE installation, I want to use it again. I installed the QT4 and GTK2 versions from the rpm repositories without any problem. But there isn't package for the QT3 version and I can't install it from the source.
I pass this option : QTDIR=/usr/lib/qt-3.3 but it doesn't work :

cd QtCurve-KDE3-1.5.0
mkdir build
cd build
QTDIR=/usr/lib/qt-3.3
cmake ..


Can you help me ?
Thank you very much for your answer ! - Aug 30 2010
Hello !

I don't know if someone made this request feature (I didn't read all comments) :
please, is it possible to let GTK apps (and DE like Gnome, XFCE...) manage their (GTK) icons themes rather than use KDE icons themes ?

Thank you ! ;-) - Jun 04 2010
Technica

Various KDE 1.-4. Styles by falco101 21 comments

Hello !

You wrote : "if you would like just the theme without the source, please send me an e-mail, and I will send you the 3mb version without source."

Your email address isn't valid anymore.
How can I get the theme without source files version ?
Can you post the link to download it, please ?


Thank you ! - Jun 03 2010
kconfigure

Developers Apps by brockers 37 comments

Hello !

- When I click on the "install" button, I have a kdesu window to write the root password (Mandriva 2009.1 Spring) : normal.
But I haven't this window in Fedora/LXDE. Kdesu is installed but when I click on the "install" button, Kconfigure doesn't ask me the root password so it hasn't root privileges to proceed the installation.

- When I want to uninstall, I have the same thing even with Mandriva 2009.1 Spring version. Kconfigure doesn't uninstall because of non root rights.

Any idea to help me, please ?
Thank you in advance for your answer ! - May 07 2010
With QTDIR=/usr/lib/qt3, the installation works fine.
Thank you ! - Dec 24 2009
Hello

I want to install the last QtCurve for KDE 3 but I have this make error :

Quote:/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/build/style/qtcurve.moc: At global scope:
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/build/style/qtcurve.moc:20: erreur: expected constructor, destructor, or type conversion before ‘static’
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/build/style/qtcurve.moc:49: erreur: ‘const QMetaObject QtCurveStyle::staticMetaObject’ is not a static member of ‘class QtCurveStyle’
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/build/style/qtcurve.moc:51: erreur: ‘qt_meta_data_QtCurveStyle’ was not declared in this scope
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/build/style/qtcurve.moc:52: erreur: braces around initializer for non-aggregate type ‘const QMetaObject’
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/build/style/qtcurve.moc:54: erreur: prototype for ‘const QMetaObject* QtCurveStyle::metaObject() const’ does not match any in class ‘QtCurveStyle’
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/style/qtcurve.h:69: erreur: candidate is: virtual QMetaObject* QtCurveStyle::metaObject() const
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/build/style/qtcurve.moc:59: erreur: no ‘void* QtCurveStyle::qt_metacast(const char*)’ member function declared in class ‘QtCurveStyle’
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/build/style/qtcurve.moc:67: erreur: ‘int QtCurveStyle::qt_metacall’ is not a static member of ‘class QtCurveStyle’
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/build/style/qtcurve.moc:67: erreur: ‘Call’ is not a member of ‘QMetaObject’
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/build/style/qtcurve.moc:67: erreur: expected primary-expression before ‘int’
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/build/style/qtcurve.moc:67: erreur: expected primary-expression before ‘void’
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/build/style/qtcurve.moc:67: erreur: initializer liste d'expressions traitée comme une expression composée
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/build/style/qtcurve.moc:68: erreur: expected ‘,’ or ‘;’ before ‘{’ token
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/common/colorutils.c:240: attention : ‘color ColorUtils_shade(const color*, double, double)’ defined but not used
/home/sebmaurice/Mes_Telechargements/QtCurve/QtCurve-KDE3-0.69.1/style/qtcurve.cpp:8013: attention : ‘void recolour(QImage&, const QColor&, double)’ defined but not used
make[2]: *** [style/CMakeFiles/qtcurve.dir/qtcurve.o] Erreur 1
make[1]: *** [style/CMakeFiles/qtcurve.dir/all] Erreur 2
make: *** [all] Erreur 2

I have this error with several lasts versions and I can install the KDE 4 and the GTK 2 versions without any problem.


Can anyone help me, please ?
Thank you very much for your answer ! - Dec 23 2009
Liquid GTK

GTK1 Themes by Yaba 27 comments

Hello !

Freshmeat has changed his site and I can't find the themes section. Can someone post a download link to get the xliquid gtk 1 version theme ?
Thank you very much ! - Dec 23 2009