transKode

Amarok 1.x Scripts by attendant 126 comments

you're right. transkode has 3 dependencies: qt3, kde3 and taglib.
i have not the slightest idea why so many unneded dependencies are added to the resulting binary but the whole thing has become really frustrating. i've tried compiling it with 3 different distros (kubuntu, opensuse & gentoo) and i still was not able to build a binary that would work in the other 2 distros without installing additional packages :-( let alone without unneded dependencies...
if anyone has any clue of what can be causing those dependencies, i'll be happy to hear about it. otherwise i'll just release a new package with the binary built in kubuntu (the one with the least amount of unneded dependencies) as a momentary "fix" (something i should probably have done before anyway...)
at this point, i'm seriously considering going back to python (or ruby or other interpreted language) for the KDE4 port... - Feb 04 2008
transKode

Audio Apps by attendant 84 comments

you're probably ussing an older version. support for reading metadata from mp4 (and other formats) was added in 0.7beta. - Feb 04 2008
Subtitle Composer

Video Apps by attendant 181 comments

well, i can't see why not :-)
unfortunately, i'm in the middle of my exams, so i won't be able to
help much for awhile (that is, if you need help getting started). - Jan 29 2008
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

try updating to the last version of the script. - Jan 23 2008
Subtitle Composer

Video Apps by attendant 181 comments

kross scripting support is planned after the (already in progress) port to KDE4. - Jan 18 2008
Subtitle Composer

Video Apps by attendant 181 comments

i can't reproduce this problem with either mplayer or gstreamer.
what video backend are you using? - Jan 08 2008
Subtitle Composer

Video Apps by attendant 181 comments

you're right of course... sorry. - Jan 08 2008
Subtitle Composer

Video Apps by attendant 181 comments

yes, you're mistaken. it seems you're using the "open subtitle" option to load a video file (you should use that to select the subtitle file and the "open video" option to select the video). - Dec 30 2007
Subtitle Composer

Video Apps by attendant 181 comments

this and support for translating subtitles is planned for next version.
a non definitive plan of next versions features can be found on the TODO file. - Dec 19 2007
Subtitle Composer

Video Apps by attendant 181 comments

i'll take a look at it. - Dec 17 2007
Subtitle Composer

Video Apps by attendant 181 comments

just to be clear, not a problem with (or in) kdelibs but just related to it... (probably, that method was added recently). - Dec 17 2007
Subtitle Composer

Video Apps by attendant 181 comments

looks more like a problem with kdelibs.
what kde version are you using? - Dec 17 2007
Subtitle Composer

Video Apps by attendant 181 comments

glad you find it useful.

Quote:My problems:
1) when i play video using mplayer backend (I don't have gstreamer), if I press "stop" and the "play" again, there is no audio. My Mplayer version: MPlayer 1.0rc1-4.0.3
the will be no more video backends until the app is ported to KDE4, when i'll add a phonon backend (unless someone else is willing to do it). i would however, try to fix the mplayer problem (which i can already confirm as a bug on my part :S) and release a fix a soon as possible. as a side note, i don't know why you don't have gstreamer, but if possible i suggest you install it as the mplayer backend can't do accurate seeking (i try to work around that, but there's only so much i can do).

Quote:2) I have'nt understood what means "link this line to the video"....
"link current line to video" (which should be "link current line to video position"), means that the current line (the active one on the view) will be automatically set according to the video position (when the video is playing). that's what the icon attempts to suggest (i guess it's not very clear though...)

Quote:My requests:
3) a spinbox for fine video timing
4) xinelib (kaffeine) backend
i'm not sure if you're referring to this, but there is already a spinbox for accurate video seeking: right click on the video information controls and check "Show editable position control" (see the 2nd screenshoot). again, this doesn't help much with mplayer as it's seek accuracy is in the order of seconds... (i think mplayer can only jump through key frames).
btw, kaffeine can't be used as a video backend but xinelib can. - Dec 16 2007
transKode

Audio Apps by attendant 84 comments

ok then. i'll play with it to see how it works. - Nov 27 2007
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

the file if 'wikilyrics.rb' under 'cli' directory.
note, however, that the documentation on the wiki might be outdated. - Nov 27 2007
transKode

Audio Apps by attendant 84 comments

i don't. what i meant is that if i create the named pipe "transkode.pipe" first, and then instruct decoder X to output to "trankode.pipe", i believe that it would just replace the named pipe with a regular file; however, if decoder X supports writing to stdout, i can actually redirect the output to a named pipe (though i would have to do that myself, that is intercept the output and send it to the pipe). again, i might be missing something (or maybe i just got this totally wrong?) - Nov 26 2007
transKode

Audio Apps by attendant 84 comments

i don't think i can make encoders write to a named pipe unless they can output to stdout (and not all of them can do it). is there another way i'm missing?
- Nov 25 2007
Subtitle Composer

Video Apps by attendant 181 comments

thanks for the clarifications.
2. again, doable (not sure it buys much, but it would look cooler :-)
3. already done.
i'm still not convinced about 1. if the point is going back a few seconds, then what's wrong with using the slider? granted, it currently jumps to much, but that could be arranged. there's another issue however, and it's that seeking is SLOW, issuing a lot of seeking commands simultaneously would drag the thing down (hence, it would probably suck anyway). i've added a few actions to go back and forward a configurable amount of time, and to jump to previous/next line, perhaps those could fill that use case? - Nov 16 2007
Subtitle Composer

Video Apps by attendant 181 comments

1,3. You can already seek to a given line by double clicking on it so there's no need for an additional button. given that, i don't see the need for a permanent position spinbox, though perhaps a "jump to position" dialog to allow accurately seeking could be useful for some.
2. doable, but i'll add an option to quickly enable/disable synchronization as some people (me at least) edit their subtitles with the movie playing and having the current line change on you would be very annoying. - Nov 16 2007
Subtitle Composer

Video Apps by attendant 181 comments

thanks, it's all clear now (and easily doable). - Nov 16 2007
Subtitle Composer

Video Apps by attendant 181 comments

i've been using subtitle workshop for a long time (great program btw). i've already taken many ideas from it and will surely continue to do so. - Nov 16 2007
Subtitle Composer

Video Apps by attendant 181 comments

could you elaborate? i'm not sure i'm following you... you mean something like arranging the lines by dragging them and then changing the times? (i've checked ksubtile but don't understand how it works...) - Nov 16 2007
Subtitle Composer

Video Apps by attendant 181 comments

being a (not necesarily a 1 to 1) replacement for Subtitle Workshop is kind of the stated goal (improving it would be nice too, but that's a mid term goal as i'm a bit behind ATM :-)
(to anyone interested) what are the features that you most use when editing subtitles with other programs and miss on subtitle composer? - Nov 15 2007
Subtitle Composer

Video Apps by attendant 181 comments

play and pause are already configurable actions (go to Settings->Edit Shortcuts). not sure what "step back" should do (go back a few seconds? previous line?) what exactly were you thinking?
about the automake issue, i'm not sure what the problem is but i'll release the generated configure script next time just in case. - Nov 15 2007
Subtitle Composer

Video Apps by attendant 181 comments

translation mode is high on the TODO list. - Nov 15 2007
transKode

Audio Apps by attendant 84 comments

i could, but there's already 2 entries for transkode on kde-apps and I rather not abuse the system (anymore)... sorry. - Oct 28 2007
transKode

Amarok 1.x Scripts by attendant 126 comments

i finally found the problem (and even better, a way to test the TTMD for myself :-)
the transcoding done "signal" was not properly sent in case of error to amarok (which kept waiting indefinitely as a result).
your problem however is also related to an invalid profile (this is not a bug). check the profiles configuration page (as explained before): the Amarok TTMD profile should be reported as invalid. if you're sure you have the proper encoder/decoders installed -and configured- try reverting the profiles configuration to default values. - Oct 26 2007
transKode

Amarok 1.x Scripts by attendant 126 comments

Are you using v0.7beta? If not, please try it and report back. I want to know this works (or fix it) before releasing v0.7 but I have no way to test it myself ATM.
About the profile validation failing, that's probably not a bug; it can fail for various reasons such as not finding the specified encoder or having an invalid naming scheme. Search for the Amarok Transfer to Media Device profile on the profiles' configuration page to see if it's not being reported as invalid.
NOTE: the profile you should look at is named "Amarok TTMD - <extension>" where <extension> depends on your device (and the format Amarok requests as output for it), most likely "mp3", "mp4", "m4a" or "ogg". - Oct 16 2007
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

Quote:Hi! First i'd like to thank you for your great script. I love LyricWiki, and i'm a regular contributor to that site, thanks to your script. However, its interface, which used to be Qt based, shows as tk (?) in my pc. I am using Arch Linux and have no problem compiling Qt-apps. I have made a snapshot of this problem:
http://bayimg.com/gahhaAabG
yes, that's the tk backend. the script is probably not detecting the qtruby bindings. are you sure you have them installed?

Quote:Furthermore, i have a suggestion: why not an universal interface for configuring. I mean, there's a dialog everytime a component (lyricwiki, lyriki, the sources) needs a configuration. I think it would be great to have a common, single-window configuration interface. what is your opinion? Thanks in advance.
i wouldn't hold my breath on that: building such a dialog it's a real pain since all scripts are detected at runtime and (a priori) all of them could have settings to show, so there would have to be a generic method to build the dialog from the gathered "widgets". Add to that 3 (or 4) different gui toolkits and things become a lot messier. i'll see if it's doable, but don't count on it. - Oct 04 2007
transKode

Audio Apps by attendant 84 comments

you can, but you'll probably have to compile it yourself for now.
i'll upload a v0.7 script package once i get my hands on a 32bits machine. - Oct 01 2007
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

Well, fetching 2 times the same suggestions page is not the right thing to do... I'll have a look at it. - Sep 21 2007
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

nope, sorry. i should have mentioned it had been fixed in trunk...
however, i just released a new version with the fix on it. - Sep 21 2007
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

thanks for reporting. it's fixed now. - Sep 20 2007
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

do you know what gui backend is it using? (qt3/qt4/gtk/tk) - Sep 09 2007
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

i forgot... can you reproduce any of this bugs? - Sep 02 2007
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

well, that doesn't looks like a wiki-lyrics bug... nevertheless:
what distro are you running? do you have qtruby installed? if so, what version?
also, what was your sites configuration when you reported the previous issue? what amarok version were you using? - Sep 02 2007
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

i can't reproduce this with v0.12.2.
what version are you using? - Aug 30 2007
transKode

Audio Apps by attendant 84 comments

raro encontrar a alguien más del nacional acá...
volviendo al tema, tenías razón: era un bug.
si encontrás algo más avisame, así lo arreglo antes de la versión 0.7 final. - Aug 06 2007
transKode

Audio Apps by attendant 84 comments

you can already set this as part of the encoding profile settings (either globally or per profile).
future release will have this as a separate thing (there will be "naming scheme" profiles) - Aug 06 2007
transKode

Amarok 1.x Scripts by attendant 126 comments

actually, transkode _always_ decodes the input to wave with an appropriate decoder and then reencodes it with the encoder.
so in this case, lame will be doing the input decoding (or mplayer, or gstreamer) and flac will be doing the output encoding. - Jul 30 2007
transKode

Amarok 1.x Scripts by attendant 126 comments

it should...
but to figure out what's wrong, i'll need more information: what error are you seeing? can you show me the program log? do you have lame and flac installed? has the program recognized them? (in the configuration dialog select the "programs" page and click the "guess" button for both lame and flac, if you get a full path instead of the name, the program was found, otherwise it wasn't -there should be an indication for that... i'll add it in the next release) - Jul 28 2007
transKode

Amarok 1.x Scripts by attendant 126 comments

maybe it has something to do with the way transkode works. currently, when a subprocess is started the worker thread enters a loop where it 1) sleeps for a second and 2) checks if the subprocess has finished, aborted or whatever (to know when to quit the loop). maybe that's why you see transkode sleeping when there are jobs still in the queue. this however doesn't means that transkode is not working: the subprocesses keep running uninterruptedly and are the ones actually using the CPU.
btw, next version will support multiple simultaneous encodings (already implemented). - Jul 17 2007
transKode

Amarok 1.x Scripts by attendant 126 comments

oops... i missed that one. you can't add characters from the dialog but you can edit the "replace_chars" entry in the application config file.
thanks for reporting, i've already fixed it for the next release. - Jul 16 2007
transKode

Audio Apps by attendant 84 comments

the encoder is most likely lame, but that really depends on the profile your using. set the log file setting in the configuration to get the generated command line (you'll actually get the list of args separated by colon).
now, what you describe doesn't like a problem with the encoding switches (which are lame standard settings). i suggest you try encoding to vorbis ogg or another format. if you can actually hear any sound (that is, if it's not a problem with your mixer settings), then it's probably a problem with your lame binary. - Jul 12 2007
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

in Amarok tools menu select "script Manager". once in the script manager you can either:
a. select "get more scripts", then search "Wiki-Lyrics" and press install (or download, i don't remember exactly).
b. select "install script" and search for the file you can download in this page.
- Jul 11 2007
transKode

Amarok 1.x Scripts by attendant 126 comments

i can compile on amd64 just fine...
are you sure this is a transkode issue?
have you tried compiling another kde app?
- Jun 20 2007
transKode

Amarok 1.x Scripts by attendant 126 comments

i hadn't thought about this before but you're totally right, i would also be very annoyed by it. i haven't seen this working myself yet, that's why this obvious "bug" slipped by (so thanks for reporting).
for now, i suggest you change the naming scheme of the profile used to transfer files to devices (amaroK TTMD - EXTENSION) to point to a temp dir (that would be the default behavior, had i realized this before...)
- Jun 14 2007
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

it seems the config file is corrupt. try removing the script config file:
rm $HOME/.kde/share/apps/amarok/scripts-data/wikilyrics.xml
i'll try to fix this for the next release - Jun 09 2007
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

can you reproduce this? if so, how? - Jun 05 2007
Wiki-Lyrics

Amarok 1.x Scripts by attendant 191 comments

that's strange... try using other sites (press the configure button and adjust the sites to query) - May 26 2007